ESP8266 blaue led bleibt bleibt auf

Ich habe eine ähnliche Frage an meine gestellt, aber es gab keine gute Antwort.

Ich habe meinen ESP8266 mit Arduino UNO verbunden.

Dann bekam ich Probleme mit der seriellen Software-Kommunikation mit Arduino und entschied, die Baud-Rate auf 9600 zu ändern (vorher waren es 115200).

Ich habe AT + IPR = 9600 Befehl verwendet, um es zu ändern.

Danach bleibt die blaue LED von esp eingeschaltet und nimmt keine AT-Befehle mehr, sondern gibt etwas Kauderwelsch zum seriellen Monitor aus.

Hinweis: Ich habe den esp8266 über einen Spannungsregler und eine Stromquelle angeschlossen, und beide haben das gleiche Problem verursacht. Meine Firmware soll aktualisiert werden, also glaube ich nicht, dass es das Problem ist.

Könnte mir bitte jemand helfen?

0
Sie haben die Baudrate geändert. Versuchen Sie, die Baudrate Ihrer UNO mit Ihrer neuen Baudrate abzustimmen. Nicht übereinstimmende Baudraten werden tatsächlich Kauderwelsch verursachen. Vielleicht ist die "aktualisierte Firmware" tatsächlich das Problem, da das Gerät nicht gut reagiert, versuchen Sie die Firmware neu zu aktualisieren (wenn Sie wissen, welche Baudrate es ist).
hinzugefügt der Autor dotnetengineer, Quelle

1 Antworten

Hast du die Firmware geändert? Ich denke, Baudrate kann nur geändert werden, wenn Sie es mit neueren Firmware-Version flashen.

0
hinzugefügt
Wie von Paul erwähnt, haben Sie versucht, die Firmware neu zu laden? Ich fand Nodemcu Flasher als den einfachsten Weg, die Firmware hochzuladen. Auch erstellen Sie sich ein einfaches blinkendes Setup wie dieses . Es lohnt sich, wenn Sie ESP8266 verwenden möchten.
hinzugefügt der Autor Vince Panuccio, Quelle
Ja ich habe die Firmware geändert. Das Problem ist, dass es beim Versuch, die Baudrate zurück zu ändern, keine AT-Befehle akzeptiert, obwohl ich mit verschiedenen Baudraten versucht habe.
hinzugefügt der Autor KeithS, Quelle