Fehler beim Installieren von Alfresco Community 4.0.b - Unbeendete UQoted-Zeichenfolge

Wenn ich versuche, Alfresco 4.0.b unter Ubuntu 10.04 im Textmodus zu installieren, bekomme ich den Fehler:

./alfresco-community-4.0.b-installer-linux-x64.bin: 1: Syntax error: Unterminated quoted string

Ist das mit dem Installer oder Ubuntu verbunden? Einige helfen, es zum Laufen zu bringen?

0
Mein Verdacht ist, dass Sie einen korrupten Download haben - können Sie den MD5-Hash Ihrer Datei überprüfen und überprüfen, ob dieser korrekt ist?
hinzugefügt der Autor Gagravarr, Quelle
Hast du dein Problem gelöst? Bitte markieren Sie eine Antwort oder fügen Sie Ihre eigene Antwort hinzu, wenn Sie sie selbst gelöst haben.
hinzugefügt der Autor Florian, Quelle

2 Antworten

Entweder Korruption, oder Sie arbeiten auf 32bit Betriebssystem, verwenden Sie den Befehl: uname -m dies zu wissen, wenn es etwas anderes gibt als: x86_64 dann verwenden Sie keine kompatible Version von UBUNTU, müssen Sie entweder eine 64-Bit-Version zu installieren von UBUNTU oder wählen Sie die fest codierte Installation von Alfresco, da die 4. Version kein 32bit Alfresco Installer hat.

1
hinzugefügt
uname -m gibt mir "i686"
hinzugefügt der Autor Kris, Quelle
Vor langer Zeit! Dann arbeiten Sie an 32-Bit-Betriebssystemen!
hinzugefügt der Autor Yazid Erman, Quelle

Hatte das gleiche Problem, behob es aber, indem ich sicherstellte, dass die .bin ausführbar war von:

chmod 777 

Sie müssen es auch als root ausführen und vor dem Dateinamen './' haben:

$ ./alfresco-community-4.0.b-installer-linux-x64.bin

Ich habe sh verwendet, wie ich es gewohnt bin, Shell/Bash-Skripte auszuführen. Ich denke, das ist der Grund, warum es den Fehler "nicht in Anführungszeichen gesetzte Zeichenfolge" gab.

Könnte auch sein, dass ich chmod + a anstelle von chmod 777 verwendet habe.

0
hinzugefügt