Probleme mit der Installation von Visual Studio Express

Ich habe gerade "Visual C# 2008 Express Edition" und "Visual Web Developer 2008 Express Edition" auf meinem Vista-Rechner installiert. Zuvor habe ich diese in Win XP ausgeführt. Beim Starten der Software, beim Starten eines neuen Projekts und beim Versuch, es zu erstellen, erhalte ich Warnungen wie "Die referenzierte Komponente 'System' konnte nicht gefunden werden."; eine Zeile für jeden verwendeten Namespace. Ich habe .NET Framework 3.5 installiert und kann die Registerkarten unter "Verweis hinzufügen" durchsuchen, aber ich kann es nicht funktionieren lassen. (Eine Neuinstallation hat nicht geholfen.) Gibt es eine einfache Lösung?

0
Ae Sie laufen es als Administrator? (Rechtsklick-Kontextmenü in der exe)
hinzugefügt der Autor Thomas Wagner, Quelle

4 Antworten

Starten Sie über "Als Administrator ausführen"? Es ist möglich, dass die Berechtigungen für Ihre .Net-Framework-Verzeichnisse nicht so sind, wie sie sein sollten.

0
hinzugefügt

Ich wollte wirklich nicht der angenommenen Antwort folgen und eine saubere Installation machen. Eine bessere Lösung habe ich von den MSDN-Foren bekommen:

Go to Control Panel > Programs and Features > Turn Windows Features on or off...

Then enable everything under Microsoft .Net Framework 3.0

0
hinzugefügt

Problem gelöst. Ich benutzte die radikalste Lösung, die ich mir vorstellen konnte - eine saubere Vista-Installation. Irgendwie enthält Neuinstallation Visual Studio nicht alle wesentlichen Schritte. Beim ersten Start der Software konfiguriert es sich selbst. Etwas muss beim ersten Mal schief gelaufen sein und als der Vorgang erneut durchgeführt wurde, versuchte es zu "kaputten" Konfigurationen zu kommen. Nun, jetzt ist es behoben.

0
hinzugefügt

Haben Sie Patches oder Updates für diese Software? Der andere Gedanke wäre, die System.dll in den bin-Ordner des Projekts zu kopieren, was ich in früheren Projekten getan habe, um Dinge zum Laufen zu bringen.

0
hinzugefügt